Non Working Indicators

Discussion in 'Tigra' started by Uncletone, Sep 15, 2017.

  1. Uncletone

    Uncletone

    Joined:
    Mar 27, 2017
    Messages:
    1
    Likes Received:
    0
    I changed the rear indicator bulbs on the Tigra B as one looked a little Black.

    Popped the rear lenses back in and switched on the hazards just to check and........nothing. Dash lights flashing, hazard switch flashing no indicators. OK switch on ignition and try them on the indicator stalk. All that happened was the dash lights went into hyper - flash.
    All the symptoms of a bulb blown. Now seeing as I had just changed the rear ones I thought they cant have gone but I changed them back fro the old ones nothing happened still no indicators.
    On the Forums, it says that the relays are prone to go, and all the symptoms pointed to that.m Bear in mind there is no dedicated fuse for the indicators apart from Fuse 3 which covers the dash lights. And guess where the Relay is beside the battery. Nice and easy to get to...NOT.
    OK, new relay arrives in the post from the Bay of E . Plug it in, nothing still the same, dash lights going but no indicator bulbs.
    I know the Hazard switch is working I can see it.
    Last resort, I start pulling fuses and as I get to Fuse 11 (10amp) it's blown.

    Check the manual "Fuse 11" Central Control Unit"

    No idea what that does, but replaced the fuse and ....Bingo all back to normal.

    So guys don't always think its the Relay or Fuse No3 or the Hazard Switch check Fuse 11 Central Control Unit

    Tone
     
    Uncletone, Sep 15, 2017
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.