Astra Coupe engine temp probs

Discussion in 'Astra' started by john Smith, Oct 24, 2004.

  1. john Smith

    john Smith Guest

    Hello,

    I have recently bought a "51" 2.0l Turbo astra coupe with 55k on the clock
    and a FSH.

    I have just taken it for a spin in the hills, first dry day since I bought
    it, and I have noticed a problem with the

    engine temperature.

    My old 1.8 Astra's temp was always bang in the middle of the gauge.

    I have noticed with this one the temp is all over the show, anywhere form
    cold to midway.

    I especially noticed it when I had the heaters on full, with the windows
    open feeling the wind in what is left of my hair.

    The temp was reading "0". I thought the sender had come off, until I turned
    the heaters off, everything seemd back to normal after

    10 minutes.

    I tried it agin a while later and it happened again.

    Any help would be gladly appreciated.
     
    john Smith, Oct 24, 2004
    #1
    1. Advertisements

  2. john Smith

    Me2 Guest

    Sounds like thermostat is stuck open.
    Start the car up from cold and feel the radiator pipes. They shouldn't get
    warm till guage is showing about 95 degrees and stat opens then you should
    feel warm water flowing through them and rad getting warm.
    If pipes warm up straight away as engine temp increases, stat is stuck open
     
    Me2, Oct 24, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.