1998 Vectra stalling, MIL light on, but no fault codes in ECU memory

Discussion in 'Vectra' started by gerryo, Oct 15, 2005.

  1. gerryo

    gerryo Guest


    My 1.8L 1998 Vectra has developed a problem recently, not found
    anything like it on the groups before.

    Scenario 1: After a cold start.

    Driving to work, suddenly feel the car hesitate, like a misfire, then
    it picks up. About a minute later, the rev counter swings wildly
    between 2000 & 3500 revs, the engine no longer responds to the throttle
    & stalls (all dash light come one). I slip into neutral, turn off/on
    the ignition, engine responds, dash lights go out except the MIL. MIL
    stays on until journeys end. Problem does not occur again for the
    remainder of the journey.

    Scenario 2: After a warm start.

    MIL comes on, but everything is fine.
    No problems occur during the journey.

    NOTE: after a long stopover, MIL light is off when started & problem
    described in scenario 1 may not occur if journey is short.

    So far, I have tried the paper clip method to read the fault codes,
    there appear to be none. As a test, if I turn on the ignition with the
    paper clip in place, but do not start the engine, I get the fault codes
    for the camshaft/crank sensors flashed.

    Is it possible for the engine to deveop a fault, but not store a fault
    code in ECU memory?

    Can some of the other systems (immobiliser/abs/etc) also illuminate the
    MIL if they develop a fault?

    This problem appears like the infamous IAC or TPS problem, except I've
    had the IAC problem before & that usually caused the car to stall when
    stopped at junctions (not at speed) & a restart would not cause the MIL
    to stay on.

    Not sure if this is connected or not, but I've noticed the engine seems
    to stay warm for a lot longer than usual. The temperature gauge is
    reading normally, but to me, the engine seems hotter, if I leave it &
    start it after 30 minutes, the gauge climbs to normal temperature
    quickly. I might be reading too much into that, however.

    This problem might be connected to a journey I made about a month ago,
    it was a hot day, got stuck in a slow moving tailback & the engine
    really heated up. Not overheated, the electric fan came on several
    times. Once I got moving again, I heard a whistling noise from the
    engine bay, stopped to take a look, found nothing. Was driving to the
    airport, so did not have time to look into it more.

    Stall problem started happening about a week ago.

    Anybody seen anything like this before?

    gerryo, Oct 15, 2005
  2. You dont mention if the engine misfires or looses power whilst the tacho is
    jumping about, rather than just dying, but this definately sounds like the
    infamous CPS problem.

    Tim \(remove obvious\), Oct 15, 2005
  3. gerryo

    gerryo Guest

    Well, it's hard to say what's really happening, the engine might be
    still firing, I do see the power dropping, speed falling off.

    As you probably know, when the engine dies, PAS dies too, so I have
    about 10 seconds to get the engine going again before the steering
    becomes very difficult. Yes, it's possible the engine is still running,
    but usually, when all of the dash lights are on, the engines stalled.
    Next time, I'll be able to make a better judgement, I'll just let it
    coast to a stop (assuming it's safe to do so).

    What's the CPS, or is that a typo, should it be TPS?

    If it is the TPS, why does it die, then recover when the engine is
    restarted & go on to work fine until the end of the journey?

    Is there some way to fix it?

    gerryo, Oct 15, 2005
  4. gerryo

    gerryo Guest

    Ok, replying again to myself ;)

    Looked on net for CPS = Crankshaft Position Sensor AKA crankshaft
    sensor, Ok, I got it.

    Yeah, I suspected this, was looking at it today, it looks to be a
    ba$tard to replace, have to take the PAS pump out first, although some
    web discussion seemed to say you could remove the exhaust heat sheild +
    dipstick & do it that way. Hmm, there's a few Torx headed bolts, have
    to buy a set of sockets.

    I think you are correct Tim, it must be intermittent. It's strange how
    they fail, do you know if it's a passive (magnetic pickup) or active
    (hall effect) sensor?

    Actually, this sounds like the exact same problem as on my wife's
    Hyundai coupe, the crank sensor used to go open circuit when it heated
    up. Used to work fine when it was cold or had time to cool, but if you
    stopped the car when it was hot, there was no way to get going again.
    Hard to believe such as simple failure could disable the car.

    I bet the Vectra overheating episode caused it to begin the decent into
    premature aging. Damned tailbacks.

    Guess I'd better buy a replacement

    gerryo, Oct 15, 2005
  5. Actually no, CPS is camshaft position sensor.

    CAS is crank angle sensor.

    Both fail with frightening regularity on the ecotecs, although check the CPS

    Tim \(remove obvious\), Oct 15, 2005
  6. gerryo

    gerryo Guest

    Is there a simple test I can do, because there are no error codes
    stored, but I get the them if I turn on the ignition with the engine

    Was going to purchase a new CAS, but if it might be the CPS, then I'd
    better be sure to buy the right part.

    I can trace the CAS lead to a connector near the top right of the
    engine bay, but I can't seem to find the CPS connector, it runs down
    under the fuel injection.

    I suppose I can start the engine, pull apart the CAS connector, see if
    the MIL comes on, or is this a bad adea?

    gerryo, Oct 16, 2005
  7. gerryo

    gerryo Guest

    Changed the crank angle sensor tonight, MIL light is still on.
    Tried resetting the ECU, MIL light still comes on.

    The CAS was definitely on the way out, the insulation was frayed &
    missing from the leads at the point where it enters the sensor body.

    However, a replacement does not appear to have fixed the problem.

    During the week before I changed the CAS, the time to failure shortened
    each day, eventually it just failed (I assume) as the MIL came on

    Plan to change the CPS tomorrow night, hope this fixes it for good.

    Thing is, if the CAS was faulty, & the CPS was faulty at the same time,
    I would expect the engine to refuse to start, or else stop
    (inconveniently) every so often.

    If I short ALDL pins 5 & 6, turn on the ignition, I get the flash codes
    for CAS + CPS + ignition coils, which is what I would expect if the
    engine is not running.

    Get none of these when it does start, except the MIL illuminates after
    about 1 second.

    The engine is definitely rev limited at about 4200.

    gerryo, Oct 26, 2005
  8. gerryo

    gorourke Guest

    Went to change the camshaft sensor tonight, using the procedure from
    the following site (appears to be offline ATM)


    Took a bit more effort, my Vectra has 2 pipes running between the air
    filter box & the cambelt cover.Not sure if they are Air-con or PAS. Got
    the cambelt cover off, the belt seems slack. I remember someone posting
    previously that a slack cambelt can cause the MIL to illuminate.

    I'm now concerned the belt has jumped a few teeth & the timing is out,
    causing the MIL to light up & the revs to be limited.
    With the cambelt cover off, the section of belt on the right is not
    really pressing against the roller with any great amount of tension.
    I can rotate the roller on the right side easily with just finger
    pressure, where as the one on the left is tensioned too tightly.

    Is there some way to check the tensioner is set correctly?

    The cambelt + rollers + water pump were all changed about 22K miles
    Not sure if the tensioner was changed, I could go & ask.

    I suppose I can go ahead & change the CAS sensor anyway, but I suspect
    htis won't fix the problem.
    Is it easy to check whether the belt has slipped?

    gorourke, Nov 4, 2005
  9. gerryo

    mikeFNB Guest

    my guess would be to get the slack sorted first, I would also surmise that
    'if' the teeth had jump, you should be getting some additional problems as
    well, rather than just limited revs.

    I'd go ask if the tensioners were changed if you can confirm this, if not
    change them and then restart your diagnostics,

    slack will cause the cambelt sensor to give erratic readings.

    mikeFNB, Nov 4, 2005
  10. gerryo

    gorourke Guest

    Job Done!!
    Was the camshaft sensor all the time, replacement cured it.

    Chris, took your advice & signed up to www.cavweb.co.uk.
    Loads of good info there.

    mikeFNB, found a "how to" on cavweb, cambelt change.I read through this
    & found a section dealing with belt tension. My cambelt seems tensioned

    Chris, I manually lined up the timing points on the sprockets, all were
    in alignment, so no problem there.
    Also, checked with the guy who did the cambelt last time, the tensioner
    was changed, so no worries about it failing (touch wood).

    So, everything back to normal again.

    With regard to the ECU & failure codes, although my Vectra has an ECU
    that will flash fault codes (paper clip trick), it does not seem to do
    this when the engine is running. It will flash when the ignition is on,
    but the engine off. However, that's of limited use.

    Only people with Tech 2's in my area are main dealers, they have long
    queues (2 week wait for testing is normal), so I won't be going near
    them anytime soon. I believe the ECU will reset the stored faults after
    25~30 starts (or if I feel like it, I can switch the ignition on/off
    that many times).

    The MIL is off, will do a proper run tomorrow, see if I can get above
    4200 REVS.

    Thanks for the help

    gorourke, Nov 5, 2005
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.